import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)([\\w_-]{11})\\.(mp4|mkv|flv)$";
final String string = "ATI Stream OpenCLâ„¢ Technical Overview [Part 1] - What is OpenCLâ„¢-ecYIsu83c0I.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 2] - What is OpenCLâ„¢ (Continued)-PxPs9yKs5P8.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 3a] - Resource Setup-EbXf7MRXlpE.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 3b] - Resource Setup-uaevrJbksA0.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 4a] - Kernel Execution-IBTH2tDLqXU.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 4b] - Kernel Execution-SzymylQaA5w.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 5a] - Programming with OpenCLâ„¢ C-KFAkUsn4YPg.mkv\n"
+ "ATI Stream OpenCLâ„¢ Technical Overview [Part 5b] - Programming with OpenCLâ„¢ C-Jt4iTDvGdNE.mkv\n"
+ "ATI Stream Technology Driving the Future of HPC--LXAa8wm23E.mkv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}