import re
regex = re.compile(r"^(.*)([\w_-]{11})\.(mp4|mkv|flv)$", flags=re.MULTILINE)
test_str = ("ATI Stream OpenCLâ„¢ Technical Overview [Part 1] - What is OpenCLâ„¢-ecYIsu83c0I.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 2] - What is OpenCLâ„¢ (Continued)-PxPs9yKs5P8.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 3a] - Resource Setup-EbXf7MRXlpE.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 3b] - Resource Setup-uaevrJbksA0.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 4a] - Kernel Execution-IBTH2tDLqXU.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 4b] - Kernel Execution-SzymylQaA5w.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 5a] - Programming with OpenCLâ„¢ C-KFAkUsn4YPg.mkv\n"
"ATI Stream OpenCLâ„¢ Technical Overview [Part 5b] - Programming with OpenCLâ„¢ C-Jt4iTDvGdNE.mkv\n"
"ATI Stream Technology Driving the Future of HPC--LXAa8wm23E.mkv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")