using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data\[(\d{1,3})\](?![\s\S]*data\[\d{1,3}\])";
string input = @"<body>
<h2>JavaScript Regular Expressions</h2>
<p>TEST</p>
<p>data[01]</p>
<button onclick=""myFunction()"">Try it</button>
<p>data[02]</p>
<p>TEST</p>
<p id=""demo"" test=data[03]></p>
</body>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}