import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "data\\[(\\d{1,3})\\](?![\\s\\S]*data\\[\\d{1,3}\\])";
final String string = "<body>\n"
+ "<h2>JavaScript Regular Expressions</h2>\n"
+ "<p>TEST</p>\n"
+ "<p>data[01]</p>\n"
+ "<button onclick=\"myFunction()\">Try it</button>\n"
+ "<p>data[02]</p>\n"
+ "<p>TEST</p>\n"
+ "<p id=\"demo\" test=data[03]></p>\n"
+ "</body>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}