const regex = /\bcool\b(?:(?!\b(cool|good)\b).)*\bgood\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcool\\b(?:(?!\\b(cool|good)\\b).)*\\bgood\\b', 'g')
const str = `cool randomtext1 cool randomtext2 cool randomtext3 good cool`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}