# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ \$\K\s*((?:[^<$\s]+|(?!\s+[<$])\s+)*)\s*(?=(?:<(*ACCEPT)|\$|$)(*SKIP)(*F))
|(?!^)<\K\s*((?:[^<$\s]+|(?!\s+[<$])\s+)*)\s*(\$?)
|[^$]+(*SKIP)(*F)/ \1\2 \3/gx;t' <<< "random < test
nope $ foo $ bar < a $ qux < biz$fx<hk$
$foo<bar<baz$ foo buh<bar<baz$
$ foo $ a < z $ a <b <z$
"