$re = '/ \$\K\s*((?:[^<$\s]+|(?!\s+[<$])\s+)*)\s*(?=(?:<(*ACCEPT)|\$|$)(*SKIP)(*F))
|(?!^)<\K\s*((?:[^<$\s]+|(?!\s+[<$])\s+)*)\s*(\$?)
|[^$]+(*SKIP)(*F)/x';
$str = 'random < test
nope $ foo $ bar < a $ qux < biz$fx<hk$
$foo<bar<baz$ foo buh<bar<baz$
$ foo $ a < z $ a <b <z$
';
$subst = " \1\2 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;