use strict;
my $str = 'random < test
nope $ foo $ bar < a $ qux < biz$fx<hk$
$foo<bar<baz$ foo buh<bar<baz$
$ foo $ a < z $ a <b <z$
';
my $regex = qr/ \$\K\s*((?:[^<$\s]+|(?!\s+[<$])\s+)*)\s*(?=(?:<(*ACCEPT)|\$|$)(*SKIP)(*F))
|(?!^)<\K\s*((?:[^<$\s]+|(?!\s+[<$])\s+)*)\s*(\$?)
|[^$]+(*SKIP)(*F)/xp;
my $subst = ' \\1\\2 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";