import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \\$\\K\\s*((?:[^<$\\s]+|(?!\\s+[<$])\\s+)*)\\s*(?=(?:<(*ACCEPT)|\\$|$)(*SKIP)(*F))\n"
+ "|(?!^)<\\K\\s*((?:[^<$\\s]+|(?!\\s+[<$])\\s+)*)\\s*(\\$?)\n"
+ "|[^$]+(*SKIP)(*F)";
final String string = "random < test\n"
+ "nope $ foo $ bar < a $ qux < biz$fx<hk$\n"
+ "$foo<bar<baz$ foo buh<bar<baz$\n"
+ "$ foo $ a < z $ a <b <z$\n";
final String subst = " \\1\\2 \\3";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}