#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-6]|7[0-3]|74.0.3729.[0-1][0-2][0-9]$)"
Local $sString = "74.0.3729.021" & @CRLF & _
"72" & @CRLF & _
"5" & @CRLF & _
"20" & @CRLF & _
"73" & @CRLF & _
"72" & @CRLF & _
"68.0.3440.106" & @CRLF & _
"73.0.3683.86" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")