import re
regex = re.compile(r"^([1-6]|7[0-3]|74.0.3729.[0-1][0-2][0-9]$)", flags=re.MULTILINE)
test_str = ("74.0.3729.021\n"
"72\n"
"5\n"
"20\n"
"73\n"
"72\n"
"68.0.3440.106\n"
"73.0.3683.86\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")