re = /^([1-6]|7[0-3]|74.0.3729.[0-1][0-2][0-9]$)/m
str = '74.0.3729.021
72
5
20
73
72
68.0.3440.106
73.0.3683.86
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end