// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-6]|7[0-3]|74.0.3729.[0-1][0-2][0-9]$)").unwrap();
let string = "74.0.3729.021
72
5
20
73
72
68.0.3440.106
73.0.3683.86
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}