using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<serialCode>[a-zA-Z0-9]{0,3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>(?<=^.{5})[a-zA-Z0-9]*)?)?";
string input = @"abcfobar
abc33bar
abca3bar
abc3abar
ab3abar
c3abar
3abar
bar
ab3a3ar
c3ab4r
3aba4
bar
234f22fsdf
a23a3ar
c3ab4r
3aba4
bar
@saff
a@
4@
ab@
abc@
abcd@f
avcde@
abcdef@
abcdefg@";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}