re = /^(?<serialCode>[a-zA-Z0-9]{0,3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>(?<=^.{5})[a-zA-Z0-9]*)?)?/m
str = 'abcfobar
abc33bar
abca3bar
abc3abar
ab3abar
c3abar
3abar
bar
ab3a3ar
c3ab4r
3aba4
bar
234f22fsdf
a23a3ar
c3ab4r
3aba4
bar
@saff
a@
4@
ab@
abc@
abcd@f
avcde@
abcdef@
abcdefg@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end