import re
regex = re.compile(r"^(?<serialCode>[a-zA-Z0-9]{0,3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>(?<=^.{5})[a-zA-Z0-9]*)?)?", flags=re.MULTILINE)
test_str = ("abcfobar\n"
"abc33bar\n"
"abca3bar\n"
"abc3abar\n\n"
"ab3abar\n"
"c3abar\n"
"3abar\n"
"bar\n\n"
"ab3a3ar\n"
"c3ab4r\n"
"3aba4\n"
"bar\n\n"
"234f22fsdf\n\n\n"
"a23a3ar\n"
"c3ab4r\n"
"3aba4\n"
"bar\n\n"
"@saff\n"
"a@\n"
"4@\n"
"ab@\n"
"abc@\n"
"abcd@f\n"
"avcde@\n"
"abcdef@\n"
"abcdefg@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")