import re
regex = re.compile(r"""
^\s*(?:
(?<protocol>https?)
\:[\/\\]{2}
(?<app>[\w\-]+)
\.
(?<client>[\w]+)
\-?
(?<environment>[\w]*)
\.
(?<audience>[\w\.]+)
\:?
(?<port>\d*)
[\\\/]
(?<instance>.*?)
)\s*$
""", flags=re.MULTILINE | re.VERBOSE | re.IGNORECASE)
test_str = ("https://pii.ngkf-qa.commloanservices.com/qa2 \n"
"https://pii.ngkf-qa.pncint.net/qa1 \n"
"https://wlm-app.midlandls-qa.pncint.net/qa1-fdic \n"
"https://wlm-app.midlandls-qa.pncint.net/qa2fdic ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")