// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mxi)^\s*(?:
(?<protocol>https?)
\:[\/\\]{2}
(?<app>[\w\-]+)
\.
(?<client>[\w]+)
\-?
(?<environment>[\w]*)
\.
(?<audience>[\w\.]+)
\:?
(?<port>\d*)
[\\\/]
(?<instance>.*?)
)\s*$
").unwrap();
let string = "https://pii.ngkf-qa.commloanservices.com/qa2
https://pii.ngkf-qa.pncint.net/qa1
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic
https://wlm-app.midlandls-qa.pncint.net/qa2fdic ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}