#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(CK_\S+\b)(?=.*\1)"
Local $sString = "CK_123abc" & @CRLF & _
"foo" & @CRLF & _
"CK_abc" & @CRLF & _
"CK_123abc" & @CRLF & _
"CK_199" & @CRLF & _
"bar" & @CRLF & _
"CK_177" & @CRLF & _
"bar" & @CRLF & _
"CK_188"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")