$re = '/(?s)(CK_\S+\b)(?=.*\1)/m';
$str = 'CK_123abc
foo
CK_abc
CK_123abc
CK_199
bar
CK_177
bar
CK_188';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);