re = /(?s)(CK_\S+\b)(?=.*\1)/m
str = 'CK_123abc
foo
CK_abc
CK_123abc
CK_199
bar
CK_177
bar
CK_188'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end