using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(CK_\S+\b)(?=.*\1)";
string input = @"CK_123abc
foo
CK_abc
CK_123abc
CK_199
bar
CK_177
bar
CK_188";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}