import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?:category)(?P<category_id>[^\\/]*)(?:\\/brand(?P<brand_id>[^\\/]*))?(?:\\/mark(?P<mark_id>[^\\/]*))?";
final String string = "http://host.com/categoryXXX/brandYYY/markZZZ/page/1/otherparameters/othervalues";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}