const regex = /\/(?:category)(?P<category_id>[^\/]*)(?:\/brand(?P<brand_id>[^\/]*))?(?:\/mark(?P<mark_id>[^\/]*))?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?:category)(?P<category_id>[^\\\/]*)(?:\\\/brand(?P<brand_id>[^\\\/]*))?(?:\\\/mark(?P<mark_id>[^\\\/]*))?', 'i')
const str = `http://host.com/categoryXXX/brandYYY/markZZZ/page/1/otherparameters/othervalues`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}