re = /\/(?:category)(?P<category_id>[^\/]*)(?:\/brand(?P<brand_id>[^\/]*))?(?:\/mark(?P<mark_id>[^\/]*))?/i
str = 'http://host.com/categoryXXX/brandYYY/markZZZ/page/1/otherparameters/othervalues'
# Print the match result
str.match(re) do |match|
puts match.to_s
end