$re = '/\/(?:category)(?P<category_id>[^\/]*)(?:\/brand(?P<brand_id>[^\/]*))?(?:\/mark(?P<mark_id>[^\/]*))?/i';
$str = 'http://host.com/categoryXXX/brandYYY/markZZZ/page/1/otherparameters/othervalues';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);