package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<major>\d+)(?:\.(?<minor>\d+))?(?:\.(?<fix>\d+))?(?:\.(?<build>\d+))?`)
var str = `3.14.0.1000
3.14.0
3.14
3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}