re = /(?<major>\d+)(?:\.(?<minor>\d+))?(?:\.(?<fix>\d+))?(?:\.(?<build>\d+))?/m
str = '3.14.0.1000
3.14.0
3.14
3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end