const regex = /(?<major>\d+)(?:\.(?<minor>\d+))?(?:\.(?<fix>\d+))?(?:\.(?<build>\d+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<major>\\d+)(?:\\.(?<minor>\\d+))?(?:\\.(?<fix>\\d+))?(?:\\.(?<build>\\d+))?', 'gm')
const str = `3.14.0.1000
3.14.0
3.14
3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}