$re = '/(?<major>\d+)(?:\.(?<minor>\d+))?(?:\.(?<fix>\d+))?(?:\.(?<build>\d+))?/m';
$str = '3.14.0.1000
3.14.0
3.14
3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);