#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miU)jpg|jpeg|jpe|png|gif|webp|bmp|tiff|mp3|ogg|mp4|m4v|avi|mov|flv|swf|webm|pdf|doc|docx|txt|zip|tar|bz2|tgz|rar"
Local $sString = "https://tarmac.com/about/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")