package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?miU)jpg|jpeg|jpe|png|gif|webp|bmp|tiff|mp3|ogg|mp4|m4v|avi|mov|flv|swf|webm|pdf|doc|docx|txt|zip|tar|bz2|tgz|rar`)
var str = `https://tarmac.com/about/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}