re = /jpg|jpeg|jpe|png|gif|webp|bmp|tiff|mp3|ogg|mp4|m4v|avi|mov|flv|swf|webm|pdf|doc|docx|txt|zip|tar|bz2|tgz|rar/mi
str = 'https://tarmac.com/about/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end