using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jpg|jpeg|jpe|png|gif|webp|bmp|tiff|mp3|ogg|mp4|m4v|avi|mov|flv|swf|webm|pdf|doc|docx|txt|zip|tar|bz2|tgz|rar";
string input = @"https://tarmac.com/about/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}