$re = '/^([A-Za-z0-9][A-Za-z0-9-]*)([\.\_]?[A-Za-z0-9-]+)*(\.[A-Za-z]{2,6})+(\/[A-Za-z][A-Za-z0-9-]+)*$/';
$str = 'webmail.eltecore.com.qqqqqqqqqqqqqqqqqqq.......';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);