import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{3,20}$)[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)+$";
final String string = "// should match\n"
+ "test_test_test_tests\n"
+ "test_test_test_tests\n"
+ "t_t_t_t_t_t_t_t_t_ts\n"
+ "t_t\n\n"
+ "// length 21\n"
+ "test_test_test_tests1\n"
+ "test_test_test_tests2\n"
+ "t_t_t_t_t_t_t_t_t_ts3\n\n"
+ "// length 2\n"
+ "t_\n\n"
+ "// underscore at start and end\n"
+ "test_test_test_test_\n"
+ "_est_test_test_tests\n\n"
+ "// double underscore\n"
+ "t_t_t_t_t__t_t_t_t_t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}