$re = '/^(?=.{3,20}$)[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)+$/m';
$str = '// should match
test_test_test_tests
test_test_test_tests
t_t_t_t_t_t_t_t_t_ts
t_t
// length 21
test_test_test_tests1
test_test_test_tests2
t_t_t_t_t_t_t_t_t_ts3
// length 2
t_
// underscore at start and end
test_test_test_test_
_est_test_test_tests
// double underscore
t_t_t_t_t__t_t_t_t_t';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);