import Foundation
let pattern = #"^(?=.{3,20}$)[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// should match
test_test_test_tests
test_test_test_tests
t_t_t_t_t_t_t_t_t_ts
t_t
// length 21
test_test_test_tests1
test_test_test_tests2
t_t_t_t_t_t_t_t_t_ts3
// length 2
t_
// underscore at start and end
test_test_test_test_
_est_test_test_tests
// double underscore
t_t_t_t_t__t_t_t_t_t
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)