# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.{3,20}$)[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)+$"
test_str = ("// should match\n"
"test_test_test_tests\n"
"test_test_test_tests\n"
"t_t_t_t_t_t_t_t_t_ts\n"
"t_t\n\n"
"// length 21\n"
"test_test_test_tests1\n"
"test_test_test_tests2\n"
"t_t_t_t_t_t_t_t_t_ts3\n\n"
"// length 2\n"
"t_\n\n"
"// underscore at start and end\n"
"test_test_test_test_\n"
"_est_test_test_tests\n\n"
"// double underscore\n"
"t_t_t_t_t__t_t_t_t_t")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.