package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[media\](?:https?:)?(?:\/+)?(?:www\.)?(?:m\.)?(?:youtube\.com|youtu\.be)\/(?:watch\?v=|embed\/)?([0-9a-zA-Z_\-]+)\s*?\[\/media\]`)
var str = `[media]https://youtube.com/embed/csdfsdfY[/media]
[media]https://youtube.com/embed/su76dfAS[/media] [media]https://youtube.com/embed/csdfsdfY [/media]
[media]https://youtube.com/embed/4RErwcRsdfdY [/media]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}