$re = '/\[media\](?:https?:)?(?:\/+)?(?:www\.)?(?:m\.)?(?:youtube\.com|youtu\.be)\/(?:watch\?v=|embed\/)?([0-9a-zA-Z_\-]+)\s*?\[\/media\]/i';
$str = '[media]https://youtube.com/embed/csdfsdfY[/media]
[media]https://youtube.com/embed/su76dfAS[/media] [media]https://youtube.com/embed/csdfsdfY [/media]
[media]https://youtube.com/embed/4RErwcRsdfdY [/media]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);