re = /\[media\](?:https?:)?(?:\/+)?(?:www\.)?(?:m\.)?(?:youtube\.com|youtu\.be)\/(?:watch\?v=|embed\/)?([0-9a-zA-Z_\-]+)\s*?\[\/media\]/i
str = '[media]https://youtube.com/embed/csdfsdfY[/media]
[media]https://youtube.com/embed/su76dfAS[/media] [media]https://youtube.com/embed/csdfsdfY [/media]
[media]https://youtube.com/embed/4RErwcRsdfdY [/media]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end