use strict;
my $str = '[media]https://youtube.com/embed/csdfsdfY[/media]
[media]https://youtube.com/embed/su76dfAS[/media] [media]https://youtube.com/embed/csdfsdfY [/media]
[media]https://youtube.com/embed/4RErwcRsdfdY [/media]
';
my $regex = qr/\[media\](?:https?:)?(?:\/+)?(?:www\.)?(?:m\.)?(?:youtube\.com|youtu\.be)\/(?:watch\?v=|embed\/)?([0-9a-zA-Z_\-]+)\s*?\[\/media\]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}