#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([-\w]+)\s+(.*?)\s+,,"
Local $sString = """" & @CRLF & _
" dx d_2,222.22 ,," & @CRLF & _
" dy h..{3,333.33} ,," & @CRLF & _
"dz b#(1,111.11) ,, dx-ay relative 4,444.44 ,, " & @CRLF & _
""""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")