package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-\w]+)\s+(.*?)\s+,,`)
var str = `""
dx d_2,222.22 ,,
dy h..{3,333.33} ,,
dz b#(1,111.11) ,, dx-ay relative 4,444.44 ,,
""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}