import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-\\w]+)\\s+(.*?)\\s+,,";
final String string = "\"\"\n"
+ " dx d_2,222.22 ,,\n"
+ " dy h..{3,333.33} ,,\n"
+ "dz b#(1,111.11) ,, dx-ay relative 4,444.44 ,, \n"
+ "\"\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}