re = /([-\w]+)\s+(.*?)\s+,,/
str = '""
dx d_2,222.22 ,,
dy h..{3,333.33} ,,
dz b#(1,111.11) ,, dx-ay relative 4,444.44 ,,
""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end