const regex = /(?:\.\s+(?=[A-Z]))([^;]+(?:,\s+p\.\s+\d+(?:\-\d+)?))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\.\\s+(?=[A-Z]))([^;]+(?:,\\s+p\\.\\s+\\d+(?:\\-\\d+)?))', 'i')
const str = `"First there is a sentence or two, then a citation which I'd like to extract. Bookwriter, Johnny J., Book Title, 50th Edition, Publishing Company, United States, 2016, p. 18."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}