re = /(?:\.\s+(?=[A-Z]))([^;]+(?:,\s+p\.\s+\d+(?:\-\d+)?))/i
str = '"First there is a sentence or two, then a citation which I\'d like to extract. Bookwriter, Johnny J., Book Title, 50th Edition, Publishing Company, United States, 2016, p. 18."'
# Print the match result
str.match(re) do |match|
puts match.to_s
end