import Foundation
let pattern = #"(?:\.\s+(?=[A-Z]))([^;]+(?:,\s+p\.\s+\d+(?:\-\d+)?))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #""First there is a sentence or two, then a citation which I'd like to extract. Bookwriter, Johnny J., Book Title, 50th Edition, Publishing Company, United States, 2016, p. 18.""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}